Email Deliverability to Microsoft Office 365
Incident Report for www.pbsnetaccess.com
Resolved
This incident has been resolved.
Posted Feb 07, 2024 - 15:36 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 06, 2024 - 18:42 EST
Identified
We are resolving an issue with emailed reports and notices. Due to a change in the Microsoft spam filters, messages from PBS may have been quarantined for recipients on Microsoft 365.

We are working with our email partners and Microsoft to resolve the issue.

All emails were delivered successfully. but they may have been caught in Microsoft's phishing filters.
Posted Feb 06, 2024 - 15:44 EST
This incident affected: www.pbsnetaccess.com.